Android 14 deve impedir instalação de apps desatualizados

Google já tem requisitos mínimos de nível de Interface de Programação de Aplicação

Por Bruna Dutra
Publicado em 24 de janeiro de 2023 às 11:59
...

Android 14 deve chegar com uma mudança significativa para os usuários. O sistema operacional do Google vai impedir que a instalação de aplicativos desatualizados, para diminuir o espalhamento de malwares.

Atualmente, o Google já tem requisitos mínimos de nível de Interface de Programação de Aplicação (API, na sigla em inglês) para os apps na Play Store. Isso impede que os desenvolvedores disponibilizem versões destinadas a Androids mais antigos.

O problema é que os requisitos não impedem o sideload, download entre dois dispositivos locais, de programas desatualizados. A ideia do Google é solucionar isso no Android 14.

Requisitos API mais rígidos chegarão junto ao próximo lançamento. Quando a alteração estiver disponível, os usuários não vão mais conseguir fazer o sideload de arquivos APK para aplicativos que não atenderem ao nível de API pedido.

O Google deve começar limitando downloads de versões de aplicativos voltadas ao Android 6, aumentando em seguida.
O Google deve começar limitando downloads de versões de aplicativos voltadas ao Android 6, aumentando em seguida.Fonte:  Guido Coppa/Unsplash 

Assim, lojas de aplicativos terceirizadas não conseguirão instalar apps que não atendam às diretrizes, por exemplo. O Google deve limitar as versões antigas ao Android 6, aumentando progressivamente.

Fonte: Site TecMundo

© SDC - Todos os diretos reservados.